skipping, buffering... it doesn't work anymore



  • It almost always skips and buffers every 1-2 minutes. It buffers 2-3secs for up to 20 secs. Sometimes it buffers 3 times within a minute of playback, sometimes it plays for 5 minutes without.

    I've done everything in the pinned topics, this forum and others and just general troubleshooting:

    • change video resolution (makes no difference)
    • malware/adware scan
    • eliminating every OSX process/app possible while streaming
    • restarting every device in the house (laptop, chromecast, router, cable modem)
    • reset Chromecast factory defaults
    • no other users of my network/wifi while testing
    • change wifi channels (multiple channels tried on both 2.4 and 5GHz)
    • changing encoding bitrates of individual files
    • testing with different filetypes of varying sizes (some seem to use a lot of CPU when streaming but others seem to use very little and still buffer all the time..). .mp4, .mkv, .avi
    • toggled every option in VS
    • Unininstalled and reinstalled both VS and the Chromecast extension

    I'm within 3 meters of both the router and my chromecast device.

    Being frustrated I decided to look for alternatives... I don't like Plex because I don't want to run a server - but I tried it for the first time and guess what? It works fine for everything I've tried playing through it. Never skips - files that use 90+% CPU with VS never exceed 30%. I hate the UI but I guess this demonstrates the issue is something with VS - at least in my case.

    This dev team was really responsive (and really cool to deal with) when I had an issue before (resolved). I'd love to use and pay for this app - but it just doesn't work for me. Although I'm not positive, I'm pretty sure things used to work better before the big update. If there was a way to "roll back" I'd definitely try it.



  • In an attempt to eliminate even more variables I installed VS on a different (newer 2013) macbook pro. I tried a variety of different filetypes over the course of the day and they all eventually start skipping/pausing.

    The same files work fine using VLC or Plex.

    I've eliminated/replaced/rebooted every variable except my router now. It is an Apple Time Capsule - so not really obscure hardware. The firmware is updated and it is within 3 meters of both the computer and the chromecast.

    So frustrating.



  • Hey Akidd,

    Really really sorry about this. After reading your post pulled up an old version of the app and posted it below. Could you give it a try and let me know if the videos work on it?

    If they do we'll work hard this week at figuring out what we broke :(

    https://chrome.google.com/webstore/detail/videodream-stream-meme/ngdapedkmcpanjbncehodepboggbcppj

    (sorry about the ulginess)



  • Thanks for this, "Videodream stream meme" working perfectly, like Videostream used to until first week of Feb 2015. Had tried everything that OP did, in addition added SONAR exception for NAV. Nothing fixed the loading, buffering and chromecast crashing problems with MKV files, particularly when audio switched to AC3.



  • Well I went back to official Videostream Chrome App (v2.15.522.1) today and everything working perfectly again, no problem whatsoever.


Log in to reply