Getting Videostream to work on ChromeOS

  • Note: This will only work if your Chromebook is in developer mode AND running an Intel processor.

    For info on putting your Chromebook into developer mode (you will lose all your data), click here:

    Step 1:

    Press [ Ctrl ] [ Alt ] [ T ] to open up a command line interface
    (press all the keys at the same time)

    Step 2:

    Type "shell" into the command line interface and then hit enter.

    Step 3:

    Enter the commands (hit enter after each):
    sudo /sbin/iptables -A INPUT -p tcp --dport 5556 -j ACCEPT
    sudo /sbin/iptables -A INPUT -p tcp --dport 5558 -j ACCEPT

    Step 4:

    At this point you should be all good to go! Sit back and enjoy videostream!

    *Note: You will need to do this each time you restart your Chromebook (we're working on a way to make it permanent)

    If you're still having issues shoot us an email at
    (We don't outsource any of our support - in less then 15min you'll be talking to the people who build Videostream)

  • I'm not sure if I'm replying in the right place; I was funneled here . . .

    To get around not being able to cast from my chromebook, I went into my xfce4 crouton and installed Chrome (the browser) -- inside the linux that is "inside" ChromeOS. That worked OK, but when trying to use Videostream from within this setup, I'm told there is a firewall blocking me.

    Is it ever going to be possible to videostream from within a crouton? Or should I uninstall Chrome from within the linux crouton and just use the built-in Firefox? I know of the workaround for the ChromeOS, so I'll stay there if need be. Having options is nice, though.

Log in to reply