[Developer Post] NaCl Missing Warning

  • If you're getting the popup in Videostream telling you that NaCl (or Native Client) has not been detected in Google Chrome not to fear!

    A couple things could be going wrong:

    1. If you are running Chromium instead of Google Chrome then your build of Chromium may have come without NaCl support. Try to use Chrome instead when available and if it's not - grab a version of Chromium with NaCl enabled (email us if you need help with this)
    2. Type Chrome://flags into your address bar and hit enter. Ensure that all boxes related to NaCl/Native Client are enabled
    3. Do the same for Chrome://plugins

    If you've done all of these steps you should be good to go! If you're not, shoot us an email and we'll get you up and running: team@getvideostream.com

  • Could you email me a version of Chromium with NaCl enabled?

  • @unni79 Sorry for the delay getting back to you! Are you running linux? If so which distro? The version that works will depend on that!

  • I am using Chromium Version 38.0.2125.111 on Ubuntu 14.04 (64-bit) and it does not have any Nacl options in flags or plugins. Could tell me which version should I use ?

  • @massih said:

    Chromium Version 38.0.2125.111 on Ubuntu 14.04 (64-bit)

    Remove your old version and give this a try in your linux command line

    sudo add-apt-repository ppa:chromium-daily/stable
    sudo apt-get update
    sudo apt-get install chromium-browser

    *Note: each one is a separate command

  • @Jason-from-Videostream said:

    @massih said:

    Chromium Version 38.0.2125.111 on Ubuntu 14.04 (64-bit)

    Remove your old version and give this a try in your linux command line

    sudo add-apt-repository ppa:chromium-daily/stable

    Yep, done that and get this:-

    " This PPA is dead. Don't expect updates here. Stable updates go into the release as soon as they're packaged.

    Stable Channel of Chromium for Ubuntu, matching the Google Chrome Stable Channel for Linux

    "Stable" is not an opinion of the quality of what's here. That is the name of Chromium Project's release channel.

    This PPA will contain either outdated or broken Ubuntu packages 90% of the time. When packages exist here for a few days and have no problems, they're uploaded to the Ubuntu's main distro, which makes these obsolete. The only reasons this might be ahead of Ubuntu is that the version here is untested or is too broken to accept.

    Please use this for testing only. If you experience problems, please join Freenode IRC #ubuntu-chromium or email <email address hidden> .
    More info: https://launchpad.net/~chromium-daily/+archive/ubuntu/stable
    Press [ENTER] to continue or ctrl-c to cancel adding it"

    So that's a no-go then. My VideoStream actually works; I set the flag OK, (Ubuntu 14.04), BUT I STILL get the warning message!

  • I'm running Chrome and have checked both flags and plugins. It says that NaCl is enabled in both, but I am still getthing this warning. Help? I'm using version 39.0.2171.95, also, if that helps.

  • no nacl on chromium 41(latest stable in mint 17.1), no nacl flag, no nacl plugin..... wth?

    See what I'm talking about

  • Please, I've this error message with Chromium Version 43.0.2357.81 Ubuntu 15.04.
    Can you help me ?

    thanks !!!!!!

  • Great Android Application/Chrome Extension, runs perfect from my Win7 laptop on the road, just now setting it up at home.

    I'm having the same issue running VideoStream in Chromium on Ubuntu 14.10, even after installing Chromium as you directed at the start of the thread. (I also got the message about the PPA being dead...I mostly just ignored it.)

    I also went into chrome://flags and enabled NaCl.

    Thanks for the help!

  • I managed to work around Chromium not having NaCl installed by getting the Ubuntu version of Chrome from Google and installing by right click on the downloaded .deb file and opening it with Ubuntu Software Center.
    It did require a full system restart.

    It'd be nice if Chromium had NaCl and made things easy, but I don't dwell. :-|

Log in to reply