Vizio M55-D0 SmartCast - Squished Video with MKV files.



  • When streaming from Videostream to my Vizio M55-D0 display from my PC, the video stream is squished despite being a 1080p steam. The file is a Matroska encoded video. Video files of any encoded higher quality in the same file format suffer the same fate. Video files of any other encoding are not affected (DivX, XVID, MP4, etc) This squishing effect doesn't occur when streaming to my 1st generation Chromecast in any situation.

    I'm guessing this has to be a bug in the SmartCast code somewhere in the way it's handing the video stream data. Has anyone else run into this particular bug before and if you have, have you had any luck resolving it? Is this a know bug with SmartCast in general or with the SmartCode code/hardware built into these models of TV? Devs, any thoughts here?



  • This is also happening to me on my Vizio M65-D0 with SmartCast, MKV and MP4 so far that I can confirm (note: not all MKV and MP4 files are having this happen for me, only some). First time it happened was a couple of weeks ago, before that I could watch those same videos just fine. I can adjust the aspect ratio on the TV to fill it out vertically, but then it pushes the sides of the video off the screen. Also, it only does it sometimes for me, other times those same videos will play like normal.



  • Chromecast here and I have the same problem!



  • Also have M55-D0 and also same problem.
    So far I noticed this happens only with video files that are truly 1920x1080. If they are smaller resolution, they play fine. I tried adjusting MKV's container properties for various aspect ratios and "display resolutions", but video still gets squished regardless.

    I have no problem playing back the same files on my regular Google Chromecast (1st gen).



  • Yes, I'm pretty sure this a problem with Vizio's SmartCast, not videostream app.
    I was able to reproduce this using http://jell.yfish.us/ jellyfish-3-mbps-hd-h264.mkv file.
    It showed the same squished picture when I tried to play it using Videostream or when I uploaded it to Youtube.
    However, when I played back the same youtube upload using my Roku + this tv, it was full screen.



  • This post is deleted!


  • @mxxcon Thanks! read your reply after I posted. I just plugged my old Chromecast and it all worked great!! Thank you so much!


Log in to reply
 

Looks like your connection to Videostream Community was lost, please wait while we try to reconnect.