Localhost 5557: ERR_CONNECTION_REFUSED



  • cmon guys ill add to it why is there no fix yet?



  • Hi everyone, this is my first contribution to the forum. I hope it's useful.

    I solved this problem as follows:

    . I uninstalled Chrome
    . I restarted my computer
    . I deleted the Google folder on
    : APPDATA\LOCAL
    : APPDATA\ROAMING
    : PROGRAMFILES

    . I restarted my computer again
    . Then I downloaded VideoStream

    "Voilà" ... problem solved!



  • specs: Windows7 64bit

    casting from Chrome worked something happened it stopped working 3days ago...

    Casting on mobile phones working only my laptop cant did seps below still same

    . I uninstalled Chrome
    . I restarted my computer
    . I deleted the Google folder on
    : APPDATA\LOCAL
    : APPDATA\ROAMING
    : PROGRAMFILES

    . I restarted my computer again
    reinstalled Chrome and Videostream same problem..



  • I tried absolutely everything. No luck. And I mean everything.
    Frustrating because VS works fine on my other, equally configured Win 10 PC connected to the same router.
    Anyway, finally threw in the towel and did a Windows RESET (with data kept). That did the trick.
    But it's a burdensome solution.



  • Localhost 5557: ERR_CONNECTION_REFUSED con videostream

    SOLVING IT / Solucionando localhost 5557 error... en un mac

    ¿Qué hacer?

    1. Desinstalar Google Chrome (recomendado con CleanMyMac App).

    2. Descargar Video Stream App desde:

                 https://getvideostream.com/download/#
      
    3. Instalar Google Chrome.

    4. Ejecutar desde la ventana de Google Chrome lo siguiente:

      4.1 Sincroniza to Google Chrome con la cuenta de Google con la cual tienes comprada la versión Premium de Video Stream ejecutando:

                       chrome://settings/syncSetup
      
    5. Reinicia Google Chrome...

    6. Ejecuta desde la ventana de Google Chrome:

                      chrome://settings/people
      
    7. Enciende Chromecast desde el televisor que quieres ver VideoStream.

    8. Enciende el móvil y abre la App Video Stream. En Settings aparea el ordenador donde está instalado google Chrome y enlázalo con el móvil [Add Computer] (tiene que estar conectados en la misma línea wifi y aparea el móvil aceptando el apareamientro desde el ordenador).

    9. Ejecuta Video Stream desde el ordenador y abre Google Chrome e introduce:

                         http://localhost:5557/ui/
      
    10. En VideoStream deberías entrar en “Go Premium”, si te da error inténtalo de nuevo hasta que conecte… (2 o 3 intentos normalmente).

    11. Elige Choose Video y escoge la carpeta donde hay el vídeo que quieres ver en el TV. Conéctalo con Chromecast (enviar) desde el ordenador si no te lo ha hecho automáticamente…

    12. Desde el móvil abre la pestaña Scanning Vídeos y ejecuta (play) el fichero de vídeo que quieras visualizar en el TV.

    13. Funciona!

    Hasta pronto! Espero que te haya servido.
    Josep!

    2019-03-03_19-55-53.jpg

    2019-03-03_19-58-59.jpg



  • @Josep said in Localhost 5557: ERR_CONNECTION_REFUSED:
    **>
    Localhost 5557: ERR_CONNECTION_REFUSED con videostream

    SOLVING IT / Solucionando localhost 5557 error... en un mac**

    ¿Qué hacer?

    1. Desinstalar Google Chrome (recomendado con CleanMyMac App).

    2. Descargar Video Stream App desde:

                 https://getvideostream.com/download/#
      
    3. Instalar Google Chrome.

    1. Ejecutar desde la ventana de Google Chrome lo siguiente:

    4.1 Sincroniza to Google Chrome con la cuenta de Google con la cual tienes comprada la versión Premium de Video Stream ejecutando:

                        chrome://settings/syncSetup
    
    1. Reinicia Google Chrome...

    2. Ejecuta desde la ventana de Google Chrome:

                      chrome://settings/people
      
    3. Enciende Chromecast desde el televisor que quieres ver VideoStream.

    4. Enciende el móvil y abre la App Video Stream. En Settings aparea el ordenador donde está instalado google Chrome y enlázalo con el móvil [Add Computer] (tiene que estar conectados en la misma línea wifi y aparea el móvil aceptando el apareamientro desde el ordenador).

    5. Ejecuta Video Stream desde el ordenador y abre Google Chrome e introduce:

                       http://localhost:5557/ui/
      
    1. En VideoStream deberías entrar en “Go Premium”, si te da error inténtalo de nuevo hasta que conecte… (2 o 3 intentos normalmente).
    1. Elige Choose Video y escoge la carpeta donde hay el vídeo que quieres ver en el TV. Conéctalo con Chromecast (enviar) desde el ordenador si no te lo ha hecho automáticamente…
    1. Desde el móvil abre la pestaña Scanning Vídeos y ejecuta (play) el fichero de vídeo que quieras visualizar en el TV.
    1. Funciona!

    Hasta pronto! Espero que te haya servido.
    Josep

    2019-03-03_19-55-53.jpg
    2019-03-03_19-58-59.jpg



  • So I tried to download video stream but google said this site can't be reached
    localhost-5557 refused to respond



  • @tommy_L_smith I had the same issue on windows 10. I have just tried to run the installer in windows 7 compatibility mode, and now it is working. During the installation google chrome was not installed but maybe it is not the case.



  • @RobinStyle
    Thanks. I confirm that running the setup with compability mode solves the problem.



  • @Rene-Schmidt run the setup in windows 7 compability mode



  • @gelboy06 thanks, just had this error and your solution worked like a charm



  • @Rene-Schmidt
    As usual they promised a fantastic working app but at the end we just get a load of shit.
    This app sucks big time!!!



  • Hi,

    Win 1903, Chrome 76+.

    I solved the problem by using the tool VideostreamNetworkRepair.exe
    But, under Windows your network must first be set to Private !
    I didn't pay attention, mine was set to Public and the rules created by the tool in the firewall only applied to public network.
    I manually changed it to Private. Working flawlessly.

    Hope it helps !



  • it was solved as follow, uninstall videostream, now reinstal on compatibility mode set on windows 7, and that´s all folks!



  • @Rudy Thanks for your answer. I have applied it and it seems it works fine from now. Windows 10 working on an intel i5 2.90 Ghz.

    Keep fingers crossed until next time (last months I am a bit sceptical with Videostream).



  • @Rudy Thank you Rudy! This worked for me.



  • Thanks all the windows 7 solution worked for me as well. Lets not all blame Video stream Microsoft is the one putting out garbage software. If you all noticed it stopped working after the last windows update. of course who notice that anymore the bastards update your machine the middle of the night without your permission. What a bunch of asses.



  • Win 10 - v1909

    Hey All,
    I've search the internet long & hard for answers, trying different things & solutions others have had success with; However; no single suggestion worked permanently, until now....
    So, after much testing, I thought i'd share what worked for me.

    To start with, make sure your Network is set to Private.
    (if not, Set it & then Reboot)

    so, If you have any versions of videostream, Uninstall them (including removing Chrome extensions etc)
    Reboot

    Download Videostream (0.3.6) from the VS website
    Install/Run Setup (in Win 8 compatability mode)
    After Install, Navigate to:
    C:\Users\ 'Your Folder' \AppData\Local\Videostream\videostream.exe - Set to run in Win 8 compatability mode
    C:\Users\ 'Your Folder' \AppData\Local\Videostream\app-0.3.6\videostream.exe - Set to run in Win 8 compatability mode
    Reboot

    (I'm currently using Windows Defender Firewall after a ground up software rebuild)
    Delete all Inbound firewall rules regarding videostream
    Reboot

    Open Windows Firewall with Advanced Security > Inbound Rules
    create the following 3x Firewall rules
    C:\Users\ 'Your Folder' \AppData\Local\Videostream\videostream.exe - Private Network Only / TCP / work on specific ports: Range - 5556-5558
    C:\Users\ 'Your Folder' \AppData\Local\Videostream\app-0.3.6\videostream.exe - Private Network Only / TCP / work on specific ports: Range - 5556-5558
    C:\Users\ 'Your Folder' \AppData\Local\Videostream\app-0.3.6\videostream-native\videostream-native.exe - Private Network Only / TCP / Port set to 'Any'
    Reboot

    While the pc is rebooting, go unplug the Chromecast from the tv & the power supply.
    Reconnect the Chromecast to the Tv, then connect the power to the Chromecast - wait a couple of minutes for it to have rebooted.

    Launch Videostream

    I'm currently on day 4 & it's still working...

    I'm gonna email the boys at VS to get diffinitives on these firewall rules. I've already sent one, but they're not very good at responding.

    Hope that helps someone


    Update: 29th Feb, '20
    I ran a couple of Windows Updates last night (28th Feb, '20) - 1x build update & 1x .net update... it's still working...


    Spoke too soon... later that afternoon... back to 5557 error


    Even later in the afternoon:
    Reboots didn't work...

    CMD (as administrator)

    • ipconfig /flushdns >Press Enter

    Turn Private Firewall Off > OK > Warning Message for Firewall to turn On again > Click that... Firewall turns back on > Reboot

    Working Again


    UPDATE: 09.03.20
    OK, with my last testing... I found that Videostream would randomly work, or more the case, not work.
    A simple reboot sometimes made it work or stop working. I tried all sorts, logging the changes etc.

    In the end, The answer was to uninstall & delete all files regarding Videostream.

    So,
    Ensure Chrome is already installed.

    I already had 3x Firewall Rules created prior to the following actions:
    a) Videostream-native.exe to run 'specific ports' > 5556-5558 C:\Users\MJBiz\AppData\Local\Videostream\app-0.3.6\videostream-native\videostream-native.exe
    b) Videostream.exe to run 'specific ports' > 5556-5558 C:\Users\MJBiz\AppData\Local\Videostream\Videostream.exe
    c) Videostream.exe to run 'specific ports' > 5556-5558 C:\Users\MJBiz\AppData\Local\Videostream\app-0.3.6\Videostream.exe

    1a) I Uninstalled Videostream Desktop
    1b) Uninstall VS Extensions from Chrome
    Rebooted
    2) Search C drive for 'Videostream' - Deleted all files/traces
    (I didn't touch/cleanse the registry)
    Rebooted
    3) Installed Videostream Desktop 0.3.6 - No Compatability settings
    Rebooted
    4) Right click the VS shortcut on the desktop - Set Compatability to 'Windows 7'
    5) Launch Videostream

    Various Reboots / Powered up & down - Still consistantly working after a week, no failures



  • I have been screwing around with the firewall rules and currently have these:
    Videostream Chrome, Core, Desktop Application, Desktop Port (without the 5556 their program installs), Mobile & Mobile Application all set to TCP ports 5556-5558
    Plus Videostream Core & Desktop Application UDP all ports. (I got onto the UDP idea when somehow one time I installed version .040 rather than .036 - never been able to get that back again).

    I installed the desktop app with Win8 compatibility on everything. If I run the desktop app, it goes to localhost:5557 & stops. If I hit enter at that point /ui/ is added to the end and the program pops up. Or if I just run Chrome and go to localhostL5557/ui/, the same thing results. At first, it didn't see my media library but that started working when I changed rule Desktop Port 5556 to just Desktop Port.

    BUT - pairing does not work so the application is still not useable.

    Richard


Log in to reply