Keeps going back to 'Choose a Video' screen

  • I've been using Videostream for ages without issues, but the last couple of days it keeps playing videos for about a minute then dropping back to the choose a video screen. No recent hardware changes or anything else I can think to cause it.

    Any help would be appreciated!

  • This keeps happening to me as well. I've tried multiple file types, resetting the router, chrome and the browser. It worked great until a week ago....

  • I was having the same exact problem, I think it has something to do with a Chromecast firmware update that was released 3 days ago.

    It seems 1 of the creators has recognized the problem as seen over here

    *Mathieu GosbeeLevel 5
    11:40 AM (46 minutes ago)
    That last update murdered our app, Videostream, and had to panic to fix it. This happens after every update.

    These automatic updates that AREN'T being beta tested by Chromecast app developers have to stop.*!category-topic/chromecast/g8LudJsfHfc

  • I factory resetted the Chromecast after reading the link's info and it did not work.

  • Any word on this being fixed?

  • I recently tried disabling my windows defender and Avast monitoring to see if it would help but the same problem keeps happening. I would appreciate any suggestions...

  • I'm in the same boat. Did a Factory Reset, turned off firewall, rebooted the chromecast and pc to no avail. I'd really like a mod post on this seeing as it is the only think keeping me from getting a premium account.

  • i completely agree that auto updating the firmware is a horrible thing, that is one of the reasons i chose to root mine. i was lucky because several firmware versions ago there was an exploit available to root it.
    if anyone here has new chromecast "in-box" i would definetly recommend rooting it, the process does require a little technical know how and a teensy but its worth it.
    [](link url)
    to be clear, chromecast with the current firmware 22### does not currently have any known exploits for rooting. only new ones which have not been connected to internet will still have the old exploitable factory firmware.

  • Hey Everyone, this is definitely an issue right now. It seems like the update happened to either the Chrome extension or Chromecast and it's causing random drops in connectivity to the CC.

    What we're seeing in the office is the Chromecasts 'flickering' in the cast extension menu. If you leave the cast extension open for a long time are you all seeing the same thing?

    We're working on something right now to hopefully put this issue to bed forever but it's going to be a week+ before it's done

  • Also keep Google in the loop as well. They've acknowledged the issue.!topic/chromecast/oRTZVuvzXMY

  • Just ran into this at home and it looks like there is an easy (although somewhat annoying fix). Rebooting your computer should put things back into working operation

    Restarting chromecast, router and chrome didn't seem to have any effect

Log in to reply