[Developer Post] - Stuck on loading screen

  • @Jason-from-Videostream said:

    Occasionally we do see cases where people's routers are running a firewall. If you feel like this is the case, send us an email and we'll get everything figured out! team@getvideostream.com

    I'm wondering if this is my problem when using the Android Remote Application or if it's simply because my Android Device is ancient.
    So, I should mention I am running Chromecast and Videostream from a PC with older(ish) hardware on Ubuntu 12.04 LTS 64 bit. Running flawlessly since your most recent Videostream update a few days ago along with a Chrome update. Prior to that I was having problems with the Adaptive feature on videos that were otherwise crushing my processors and causing the PC to freeze up. Adaptive was helping but videos were still un-watchable. Whatever ya'll did in the new release worked. I'm happy to report everything is great and running smoothly from the 'host' PC.

    Attempting to run the Videostream Remote Android app on my Droid Bionic Android version 4.1.2 (yeah, i know) kind of works and kind of doesn't. The interface will load and connect and display the controls and the currently playing video is identified (assuming a video is started). What i think I've observed is if i don't immediately interact with the screen the app will close, if i make any changes using the controls,volume, or pause or play or adjust the slider, it will respect the change then immediately close. One additional piece of information, If I load the Android app with the video already in a paused state or without a video loaded, the app doesn't close. I sort of wondered if the video counter wasn't crashing the app? I don't know, then i read this about the firewall, but my guess is the firewall issues would either completely allow or completely deny the Apps functionality. I don't have antivirus running and I don't have the firewall enabled on my 'main/host' OS and as stated the app works perfectly, Seriously, Great work!

    Any help is appreciated. On a side note I'm looking forward to an alternate means to purchase Videostream and support you guys . I feel I've already got my moneys worth even if y'all sell it to one of the industry giants and they promptly ruin it. LOL :)

    TLDR: the android app closes almost immediately after starting.

  • @scott sounds like you have found a pretty serious bug with our App Scott!

    After the app crashes / closes do you get a popup saying that the app has crashed? If you do - could you hit the submit button? This should let us know which line it crashed on

    In the mean time we're trying to get our hands on a 4.1.2 version phone to see if that's what's causing it :)

  • Hey @Jason-from-Videostream,

    No popup about the app crashing. it just closes and the home screen appears. What i've pretty much concluded is it's something about the ad server causing the shut down. For whatever reason sometimes the ads don't load at the bottom and the app is perfectly stable for hours. After a few days, I'm actually convinced this is my issue but i don't know why. Are the ads removed from the remote app for premium members?

    The forum didn't seem to be very active so I happened to send mostly the same information to you guys via your email address. Matthew Gardner responded. He was more hopeful that the next release would eliminate mine and many other problems with the current android remote app.

    I'm happy to try and further troubleshoot this if you think it's worthwhile or I can wait for the next release and see what's up then. It's unfortunate I have a phone that Motorola decided to stop updating, but I also am in a position of having unlimited data with verizon and losing that if i upgrade with a 'new' plan' discount.

    Thanks for your time, Jason.

  • @scott said:

    I'm happy to try and further troubleshoot this if you think it's worthwhile or I can wait for the next release and see what's up then. It's unfortunate I have a phone that Motorola decided to stop updating, but I also am in a position of having unlimited data with verizon and losing that if i upgrade with a 'new' plan' discount.

    Yeah Matt's defintely right about the new update probably fixing this! We're about to do a completely overhauled mobile app and at that point this issue should be fixed.

    I'm happy to keep debugging with you if you want - but if it's not a big issue just hang tight and we'll have something shiny and new out in a couple weeks :D Just let me know!

  • @Jason-from-Videostream
    Let's see what happens after the new version is released. Thanks for your willingness.

  • @Jason-from-Videostream
    Saw a new version of the Android App tonight. Grabbed it and noticed no ads and more importantly I 'm happy to report it's running stable and smooth with my ?2 year old Android version? LOVE IT!

  • @scott Glad to help Scott! Hope you enjoy it :)

  • Hi Jason,

    My Chromecast is stuck on the loading screen. It worked fine last night. I use Apple Yosemite. There are no firewalls, no virus scans, I turned my VPN off and everything (router, Chrome, computer) has been rebooted.


  • @michellemyhre said:


    Sorry for the delayed reply here, is it stuck on the Videostream loading screen? If it is try disabling the OSX firewall all together - for some reason it decides to act up from time to time and block us (we haven't been able to figure out exactly why)

  • Just bought my chromecast. Installed it and it's working fine. BUT installed the videostream app and it's not working at all. Support doc said to run a utility for my firewall which I did. Also says to add exceptions to MS Security Essentials (but doesn't tell you how) which I did. Also says to open two ports in my firewall (but doesn't say how to do it) which I did.

    Attempted the 3 separate fixes I found you recommended and it still doesn't work. The Videostream tech support recommendations are lacking. Since I bought the product to stream videos, I would appreciate some sensible support in getting this to work. Chrome casting works fine.

    Using Windows 7 with MS Security Essentials going through a Motorola SBG6580 SURFBoard Gateway with modem. When attempting to stream video, I sometimes get the Firewall security prompt and sometimes it just doesn't work no diagnostics whatsoever - PC indicates it is casting the video but nothing on the TV. Videos never even get started on the TV. I tried the 3 solutions above but since you are not very coherent on the subject I'm not sure I did them correctly.

    Please advise. Thanks

  • @se2437 The Motorola SBG6580 SURFBoard Gateway has a firewall embedded on it - have you turned that off?

    Videostream requires a firewall settings that no other app will need to cast correctly. We're doing things that Google didn't exactly intend the Chromecast to be used for so as a result the work on your guys part can sometimes be more then we'd like it to be

  • Thanks for your reply. My intention wasn't to criticize your support but to find helpful support, i.e., how do I open the ports (router specific), how do I make changes to Security Essentials? etc. I don't know what else I can do and judging by your support blog, getting the videos to actually play seems to be a widespread problem. Any video chat support? Any constructive reply to the identical email I sent to your support team. I haven't heard anything helpful and there has been no attempt to reply to my particular circumstances.

  • An addional thought: I spent 35 years in IT developing database applications and we would NEVER allow a situation where software does not work without putting out meaningful and accessible diagnostics. What a concept......

Log in to reply